前往
大廳
主題

[Unity ML] Release21 安裝問題

夏洛爾 | 2024-06-16 00:06:31 | 巴幣 200 | 人氣 81

Unity ML Release21 安裝可能遇到以下問題

"NumPy 1.21.2 may not yet support Python 3.10."


因此在安裝方面

1.Clone the ML-Agents Toolkit Repository
會變成必須,才能使用Cloned Repository進行安裝

2.將numpy需求改為1.21.3
--Go to repository location
--Open the "ml-agents-envs" folder
--Open setup.py in a text editor
--Search for numpy==
--Change the value after the numpy== to 1.21.3

3.使用Cloned Repository進行安裝
cd /path/to/ml-agents
python -m pip install ./ml-agents-envs
python -m pip install ./ml-agents

另外Release 21搭配的Unity Package是3.0.0版本
由於Unity 2021之後好像改成experimental packages不會顯示在Package Manager,因此需要手動安裝
可參考下方網址

創作回應

更多創作