主題

讓 RPG Maker MV/MZ 在 macOS M1(Apple Silicon) 上進行遊戲測試的「臨時」解決方法

快閃小強 | 2021-08-19 08:25:10 | 巴幣 0 | 人氣 102

其實我會寫這篇文章的原因,主要是之前我在板上看到這篇
有人問說 macOS M1(Apple Silicon) 在執行遊戲測試時會馬上閃退這點,
所以我想說提供我這個「臨時」的解決方案,
看看是否可以幫助更多的 macOS M1(Apple Silicon) 使用者。

畢竟 RPG Maker MV 也已經很久都沒更新 nwjs 的版本,
而且連最新版本的 nwjs 都還沒計畫支援 macOS M1(Apple Silicon) 機種,
而且聽說這個問題在海外地區的相關論壇和 Steam 討論區到現在都還沒有很好的解決方法。

目前只有比較新的 Electron 才有支援到 macOS M1 機種

不過..如果你不太清楚如何用 Electron 部署執行測試的話,
你也可以試著下載使用看看我自己用 Electron 製作的快速執行測試的程式做為應急措施。

下載連結

RPG Maker MV(v1.6.2)

RPG Maker MZ(v1.3.2)

※ 如果你的遊戲專案版本低於我上面所提供的版本,你也可以前往以下的文章連結中進行修改。

使用方法
1.解壓縮之後將js資料夾內的「rpg_core.js」、「rpg_managers.js」這兩個檔案
複製到你的遊戲專案資料夾中,並替換原本的「rpg_core.js」、「rpg_managers.js」這兩個檔案
來讓你的遊戲可以同時相容 nwjs 和 Electron 的執行測試,但記得也要備份好原本的專案內容喔。

2.執行剛剛解壓縮後的 Game.app,將你的遊戲專案資料夾之中的「index.html」
用滑鼠拖曳進該 Game.app 執行程式的視窗之中。



另外,近期官方在 RPG Maker MV 的 Steam 公告上發佈了關於未來 macOS 支援問題,

我大概簡單翻譯一下,官方公告大概是這樣說的:

對於我們的 RPG Maker 用戶,


由於蘋果公司(Apple Inc.) 取消 OpenGL 的支援和其他額外的部分(例如取消對 32 位元軟體的支援),導致 RPG Maker MV 與最新的 macOS Big Sur(11.0以上) 的版本更新中出現了許多相容性的問題。

相信你也知道,這些都不是小的變化。我們已經做了很多調查,來了解我們能做些什麼來使 RPG Maker MV 與最新版本的 macOS Big Sur(11.0以上) 相容,並針對這個問題進行了很多討論。

但很不幸的是,更新 RPG Maker MV 以相容最新版本的 macOS Big Sur(11.0以上) 所需的工作量,不僅是令人難以置信的耗時,而且還可能會讓網路上那些大量粉絲所開發的插件無法相容,而這些插件不太可能再被更新,因為大多數比較活躍的插件開發者已經轉戰 RPG Maker MZ。

最後,我們決定放棄與這些插件的相容性,這對我們大多數的粉絲來說是一個更大的問題,
但是可以將原本用於更新 RPG Maker MV 的時間,更好地用於繼續改進的 RPG Maker 最新版本「RPG Maker MZ」。

目前 RPG Maker MV 仍可以相容 macOS 10.10 ~ 10.15 版本,但無法相容 macOS Big Sur 11.0 或更高版本。
有關作業系統支援的詳細資訊,請參閱產品規格頁面(https://tkool.jp/mv/spec/index.html)。


感謝您的諒解。


原文公告


「但是,你們真的會認為是目前官方無法解決 RPG Maker MV 的相容性問題嗎?」


送禮物贊助創作者 !
0
留言

創作回應

更多創作